Systems Status

WithSecure Elements Exposure Management - incorrect findings after 25th of April

Incident Report for WithSecure services

Resolved

This incident has been resolved.
Posted Apr 28, 2026 - 13:09 UTC

Update

Placeholder recommendations have been removed.
We continue working on removal of incorrect findings and their respective recommendations.
Posted Apr 28, 2026 - 06:45 UTC

Identified

Incorrect asset placeholders have been removed for all affected customers.
We are updating findings and recommendations, and expect this work to finish by the morning of 28th of April, resolving the issue.
Until then, we continue working on the issue with the highest priority.
Posted Apr 27, 2026 - 14:09 UTC

Investigating

We are investigating an issue where WithSecure Elements Exposure management reports vulnerabilities, findings and recommendations for non-existent software or devices for some customers. These findings were generated after Saturday, 25th of April.
Posted Apr 27, 2026 - 11:08 UTC
This incident affected: WithSecure Elements (Exposure Management).