Systems Status

WithSecure Elements portal inaccessible

Incident Report for WithSecure services

Resolved

The issue has been resolved.
Posted May 26, 2025 - 08:11 UTC

Investigating

We are investigating an issue where login to the WithSecure Elements portal fails and already logged in users receive various errors when navigating the portal.
Posted May 26, 2025 - 07:58 UTC
This incident affected: WithSecure Elements Endpoint Protection (Portal), WithSecure Elements Exposure Management (Portal), WithSecure Elements Collaboration Protection (Portal), and WithSecure Elements Endpoint Detection and Response (Portal).