Systems Status
Login to WithSecure Elements Security Center fails
Incident Report for WithSecure services
Resolved
The issue has been resolved.
We apologize for the inconvenience caused.
Posted Jul 30, 2024 - 11:16 UTC
Identified
We have identified the cause of the issue and are currently rolling back.
Posted Jul 30, 2024 - 11:01 UTC
Investigating
We are currently investigating reports that logging in to WithSecure Elements Security Center fails.
Posted Jul 30, 2024 - 10:30 UTC
This incident affected: WithSecure Elements Endpoint Protection (Portal), WithSecure Elements Vulnerability Management (Portal), WithSecure Elements Collaboration Protection (Portal), and WithSecure Elements Endpoint Detection and Response (Portal).