Systems Status

WithSecure new Partner Portal ordering outage

Incident Report for WithSecure services

Resolved

The issue has been resolved.
New orders can be filed again.

We apologize for the outage.
Posted Sep 25, 2025 - 14:22 UTC

Investigating

We are currently investigating an issue where the quoting tool in the new WithSecure Partner Portal is not working. Therefore, no new orders can be placed.

We are working on this issue with the highest priority and ask our partners to hold orders until the portal is restored.

Please follow this incident for updates.
Posted Sep 25, 2025 - 14:01 UTC
This incident affected: WithSecure Partner Portal (Ordering).