Systems Status

WithSecure Elements Portal: newly registered devices not appearing, profile changes not reaching endpoints

Incident Report for WithSecure services

Resolved

This incident has been resolved.
Posted Jan 20, 2026 - 09:52 UTC

Monitoring

We have restored the service.
You may see outdated information in WithSecure Elements Portal until all data has been updated.
We estimate that all data has updated by 04:00 UTC.
Posted Jan 19, 2026 - 19:26 UTC

Update

We are actively working on this issue and treating it as a top priority.
Posted Jan 19, 2026 - 18:37 UTC

Update

We are continuously working on a fix for this issue.
Posted Jan 19, 2026 - 16:17 UTC

Identified

We have identified further symptoms:
- Newly registered devices do not appear in the WithSecure Elements Portal.
- Removed devices reappear after page refresh.
- Assigned or updated profiles do not go through to the devices
- Operations sent from the WithSecure Elements Portal not going through to the clients
- Unmanaged devices (WithSecure Exposure Management) are not shown or updated

We continue working on the issue with the highest priority.
Posted Jan 19, 2026 - 14:13 UTC

Investigating

We are investigating an issue where newly registered devices do not appear in WithSecure Elements portal. Further, newly assigned profiles, profile changes do not reach endpoints.
Posted Jan 19, 2026 - 13:45 UTC
This incident affected: WithSecure Elements (Portal, Endpoint Protection, Endpoint Detection and Response, Exposure Management) and WithSecure Elements managed services (Co-Monitoring, Managed Detection and Response, Infinite).