Systems Status
Unexpected behavior of Software Updater in WithSecure Elements Endpoint Protection and WithSecure Client Security
Incident Report for WithSecure services
Resolved
This incident has been resolved.
Posted Jul 13, 2023 - 07:43 UTC
Monitoring
We have released the following updates:

WithSecure Elements Endpoint Protection: hotfix 70.
You can verify installation of the hotfix from WithSecure Elements portal under a hosts protection status.
This hotfix supersedes the previously released hotfix 69.

WithSecure Business Suite: Software Updater Engine 2023-07-11_01
You can verify installation from the local F-Secure Client Security Settings - Updates.

Updates for both products are installed automatically and require no user or admin action.
These updates address the issue of Software Updater detecting updates that have already been applied and asks for a restart repeatedly.
Posted Jul 11, 2023 - 13:10 UTC
Update
We have published the hotfix for WithSecure Elements addressing the issue of Software Updater triggering User Access Control (UAC) prompt asking for administrator credentials when updating third party software.

You can verify installation of the hotfix from WithSecure Elements portal under a hosts protection status. The hotfix ID is 69.
The update will be downloaded and installed automatically. Please note that it may take up to 24 hours for your clients to received it.

We continue working on the below issue with high priority and will update this incident once a resolution is available.
- Software Updater detects updates that have already been applied and asks for a restart repeatedly
Posted Jul 06, 2023 - 10:53 UTC
Update
We are in the final stages of testing the hotfix for WithSecure Elements addressing the issue of Software Updater triggering User Access Control (UAC) prompt asking for administrator credentials when updating third party software.

We will release the hotfix as soon as possible. Thank you for your patience.
Posted Jul 06, 2023 - 06:57 UTC
Identified
We have released Software Updater 2023-07-04_01 for WithSecure Business Suite products addressing the following issue:
- Software Updater triggers User Access Control (UAC) prompt asking for administrator credentials when updating third party software

We aim to release the above update to WithSecure Elements tomorrow, 7th of July and will update this page once the update is available.

We continue working on the below issue with high priority.
- Software Updater detects updates that have already been applied and asks for a restart repeatedly
Posted Jul 04, 2023 - 14:23 UTC
Update
We have released an update that reduces or resolves the issue with WithSecure Software Updater asking for administrator access when updating third party software.

The update is visible in the user interface and log files as F-Secure Software Updater Database 2023-06-19_02

We continue working on further improvements.
Posted Jun 19, 2023 - 14:55 UTC
Investigating
We are currently investigating reports of unexpected behavior of WithSecure Elements Endpoint Protection and WithSecure Client Security Software Updater.

Symptoms are:
- Software Updater triggers User Access Control (UAC) prompt asking for administrator credentials when updating third party software
- Software Updater detects updates that have already been applied and asks for a restart repeatedly

We are working on a solution to this behavior.

Please subscribe to this notification for updates.
Posted Jun 12, 2023 - 13:49 UTC
This incident affected: WithSecure Business Suite (Endpoints (Clients & Servers)) and WithSecure Elements Endpoint Protection (Endpoints (Clients & Servers)).