Systems Status
Upgrading to WithSecure Policy Manager 16 treated as fresh installation if previous version is installed to a non-default path
Incident Report for WithSecure services
Resolved
We have released WithSecure Policy Manager 16.01, which resolves the issue. You can download the new version from our download pages:
https://www.withsecure.com/en/support/product-support/business-suite/policy-manager#download
Posted Oct 16, 2023 - 07:41 UTC
Investigating
We are investigating an issue where upgrading F-Secure Policy Manager 15.x to WithSecure Policy Manager 16 results in a fresh installation when F-Secure Policy Manager 15.x was installed in a non-default installation path.

We are working on fixing the issue.

If you have already performed the upgrade and encountered the issue, please follow these instructions:

1. Stop the PMS service using CMD:

net stop wspms

2. Copy the content from
?:\Program Files (x86)\F-Secure\Management Server 5\data\events\
?:\Program Files (x86)\F-Secure\Management Server 5\data\guts2\
?:\Program Files (x86)\F-Secure\Management Server 5\data\h2db\
?:\Program Files (x86)\F-Secure\Management Server 5\data\fspms.jks
?:\Program Files (x86)\F-Secure\Management Server 5\data\fspms.db.config
?:\Program Files (x86)\F-Secure\Management Server 5\data\fspms.proxy.config
?:\Program Files (x86)\F-Secure\Management Server 5\data\fspms-ca.jks
?:\Program Files (x86)\F-Secure\Management Server 5\data\sdata

to

C:\ProgramData\WithSecure\NS\Policy Manager\Policy Manager Server\data\events\
C:\ProgramData\WithSecure\NS\Policy Manager\Policy Manager Server\data\guts2\
C:\ProgramData\WithSecure\NS\Policy Manager\Policy Manager Server\data\h2db\
C:\ProgramData\WithSecure\NS\Policy Manager\Policy Manager Server\data\fspms.jks
C:\ProgramData\WithSecure\NS\Policy Manager\Policy Manager Server\data\fspms.db.config
C:\ProgramData\WithSecure\NS\Policy Manager\Policy Manager Server\data\fspms.proxy.config
C:\ProgramData\WithSecure\NS\Policy Manager\Policy Manager Server\data\fspms-ca.jks
C:\ProgramData\WithSecure\NS\Policy Manager\Policy Manager Server\data\sdata

If prompted, select to replace any existing files.

3. Execute the maintenance tool:
C:\Program Files\WithSecure\Policy Manager\Policy Manager Server\bin\fspms-db-maintenance-tool

4. Check and ensure, the https and https ports are correctly defined in registry and match the settings for the previous F-Secure installation

Old location for settings in WithSecure Policy Manager version 15.00 (and older)
HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Data Fellows\F-Secure\Management Server 5

New location for settings in WithSecure Policy Manager version 16.00 (and newer)
HKEY_LOCAL_MACHINE\SOFTWARE\WithSecure\Policy Manager\Policy Manager Server\

5. Start the PMS service using CMD:
net start wspms


Note: replace "?" with the source drive for your previous Policy Manager installation. If you are unsure, where the old version is installed, check the following registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Data Fellows\F-Secure\Management Server 5\InstallationDirectory

An example is below:
D:\Program Files (x86)\F-Secure\Management Server 5
In this case, the source drive is D:
Posted Oct 02, 2023 - 13:39 UTC
This incident affected: WithSecure Business Suite (Endpoints (Clients & Servers)).