Systems Status

WithSecure Elements MDR and EDR - download of attachments to incidents not possible

Incident Report for WithSecure services

Resolved

The incident is resolved.

As of 6:57:24 AM UTC Administrators in non-European regions could not download attachments from incidents.

The effectiveness of investigative actions by our DRT team was impaired as attachments could not be retrieved.
However, containment and remediation jobs, such as deleting files, killing processes were not affected.

We deployed a fix at 12:35:41 UTC. Attachments are once again available for download.
Posted Oct 22, 2025 - 13:42 UTC

Investigating

We are currently investigating an issue where attachments to Incidents in WithSecure Elements MDR and EDR can not be downloaded in regions outside of Europe. WithSecure Countercept is not affected.
Posted Oct 22, 2025 - 13:10 UTC
This incident affected: WithSecure Elements (Endpoint Detection and Response).