Systems Status
WithSecure Support phone numbers in Finland unavailable
Incident Report for WithSecure services
Resolved
The issue has been resolved.

We apologize for the inconvenience caused.
Posted Jun 10, 2024 - 08:45 UTC
Investigating
We are investigating a partial outage of our telephony system. Finland based phone numbers are unavailable.

Phone numbers in other countries are not affected. Our phone numbers are listed here:
https://www.withsecure.com/en/support/contact-support/call-support

You can also create a support request through Partner Portal, eService Portal (customers with advanced or premium support) as well as from our public webform.
https://www.withsecure.com/en/support/contact-support/email-support

If you would like us to call you back, please indicate it in your support request.

We apologize for the inconvenience.
Posted Jun 10, 2024 - 07:56 UTC
This incident affected: WithSecure Support (Phone).