Systems Status
WithSecure Elements Endpoint Protection performance issues on MacOS 14 Sonoma
Incident Report for WithSecure services
Identified
We are preparing to release a new version that will address this issue during April.
There are some steps needed to prepare for the release.
For more information, please see our community:
https://community.withsecure.com/en/kb/articles/31284-pre-announcement-new-withsecure-client-for-macos
Posted Apr 12, 2024 - 11:34 UTC
Update
We are continuing the investigation into this issue.
Posted Mar 11, 2024 - 08:29 UTC
Update
We apologize for the duration of this incident and assure you that we continue working on resolving this issue with the highest priority.
Posted Jan 31, 2024 - 15:41 UTC
Investigating
We are investigating reports of WithSecure Elements Endpoint Protection causing performance issues on MacOS 14 Sonoma when using applications such as Microsoft Teams and Slack. Other applications may be affected too.
Posted Jan 19, 2024 - 08:49 UTC
This incident affects: WithSecure Elements Endpoint Protection (Endpoints (Clients & Servers)).