Systems Status
WithSecure Elements Collaboration Protection: Portal inaccessible, degraded scanning performance
Incident Report for WithSecure services
Resolved
This incident has been resolved.
Posted Jan 18, 2023 - 09:23 UTC
Monitoring
The incident is resolved,
The WithSecure Elements Collaboration Protection Portal is accessible and scanning performance restored.

We continue to monitor the situation.
Posted Jan 17, 2023 - 15:43 UTC
Investigating
We are investigating reports that WithSecure Elements Collaboration Protection portal is inaccessible.
In addition, we are investigating a performance degradation, with scanning being slower than expected.

Protection levels are not affected by this incident.
Posted Jan 17, 2023 - 14:29 UTC
This incident affected: WithSecure Elements Collaboration Protection (Portal, Scan Nodes).