Systems Status

WithSecure Browsing Protection extension not available in Google Chrome webstore

Incident Report for WithSecure services

Resolved

The WithSecure Browsing Protection extension is again available in Google Chrome webstore and can be installed.
Posted Feb 14, 2025 - 08:20 UTC

Investigating

The WithSecure Browsing Protection extension is currently not available in Google Chrome webstore.
We are working with google to restore it.
Security is not reduced, as Browsing Protection continues to work without the plugin. Certain functionality such as block pages may not display correctly.
Posted Feb 10, 2025 - 14:53 UTC
This incident affected: WithSecure Business Suite (Endpoints (Clients & Servers)) and WithSecure Elements Endpoint Protection (Endpoints (Clients & Servers)).