Systems Status

Partner Portal and eService access disruption due to third-party service incident

Incident Report for WithSecure services

Resolved

This incident has been resolved.
Posted Sep 16, 2026 - 13:28 UTC

Identified

We are currently monitoring an ongoing third-party service disruption that is affecting systems used by the Partner Portal and eService.

As a result, some partners and customers may experience intermittent errors, service degradation, or be unable to access certain portal functions. In some cases, the Partner Portal may display the message:

"Looks like the site is temporarily unavailable."

We are actively monitoring the situation with the service provider and will continue to provide updates as more information becomes available.

We apologize for any inconvenience this may cause.
Posted Sep 16, 2026 - 09:36 UTC
This incident affected: WithSecure Partner Portal (Portal) and WithSecure Support (eService).