Systems Status
WithSecure Policy Manager 16 unable to download updates for F-Secure Client Security 15.x and F-Secure Server Security 15.x
Incident Report for WithSecure services
Resolved
This incident has been resolved.
Posted Nov 22, 2023 - 13:02 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
If you continue to experience issues with WithSecure Policy Manager 16 downloading updates for F-Secure Client Security/Server Security 15.x, please empty your DNS cache.
Posted Nov 22, 2023 - 08:04 UTC
Identified
It looks like it is taking more time than expected due to some configuration issues. We are currently working on it and we will provide you with an update once it is done.

We sincerely appreciate your patience on this matter and apologize for the inconvenience caused.
Posted Nov 21, 2023 - 23:44 UTC
Monitoring
We have deployed a change to fix the issue. It will take up to 4 hours until it is available to all customers.
Updates will start automatically, no administrator action is required.
Posted Nov 21, 2023 - 15:40 UTC
Investigating
We are investigating reports where WithSecure Policy Manager 16.x is unable to download updates for F-Secure Client Security 15.x and F-Secure Server Security 15.x.
Updates for version 16 clients are not affected.
Posted Nov 21, 2023 - 13:47 UTC
This incident affected: WithSecure Business Suite (Endpoints (Clients & Servers)).