Systems Status

Partner Portal: customer contact information unavailable, affecting ordering

Incident Report for WithSecure services

Resolved

The issue has now been resolved, and full Partner Portal functionality has been restored. Customer contacts are once again visible under end customer accounts, and partners can place new orders as normal.
Posted Sep 11, 2026 - 09:10 UTC

Monitoring

A fix has been implemented and we are now monitoring the results.
Posted Sep 11, 2026 - 05:08 UTC

Identified

We have identified the root cause of the issue. A resynchronization of the affected contact information is currently in progress.

We expect the contacts to become visible again shortly. We will provide another update once the resynchronization has been completed.
Posted Sep 10, 2026 - 13:37 UTC

Investigating

We are currently investigating an issue affecting the Partner Portal where partner users across multiple regions are unable to view contact information for their end customer accounts.

As a result, partners may be unable to place new orders or make changes that require customer contact details, as the contact information is not being displayed in the portal. Automatic renewal orders continue to function normally and are not impacted by this issue.

Our teams are actively investigating the matter and we will provide further updates as soon as more information becomes available.
Posted Sep 10, 2026 - 10:24 UTC
This incident affected: WithSecure Partner Portal (Portal, Ordering).