We have identified an issue affecting the database, which has resulted in a backlog in scan and report processing.
A fix has been deployed, and the service is now recovering. We expect it to take up to 96 hours for the backlog of scans and reports to be fully processed and for normal operation to resume.
We apologize for any inconvenience this may cause and will continue to monitor the situation closely.
Posted Aug 12, 2026 - 09:08 UTC
Investigating
We are currently investigating reports of performance degradation affecting WithSecure Elements Exposure Management (XM).
Affected users may experience:
• Slow response times across the XM portal • Errors when accessing Vulnerability Management (VM) scan groups • "Failed to fetch tags" error messages • "Failed to fetch scheduling templates" error messages • Scans remaining in a Queued or Running state for extended periods • Multiple HTTP 4xx error responses • Intermittent issues impacting scan-related functionality and workflows
Our teams are actively investigating and working to restore normal service. Further updates will be provided as they become available.
We apologize for the inconvenience and thank you for your patience.
Posted Aug 11, 2026 - 11:56 UTC
This incident affects: WithSecure Elements (Portal, Exposure Management).