Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 24, 2025 - 08:00 UTC
Scheduled
We will be performing some system maintenance on our WithSecure Elements backend systems on 24th November 2025, at 8.00 UTC.
This maintenance is expected to take a maximum of 30 minutes.
During the maintenance period:
EDR/MDR-related views in Elements will be impacted Customer are still protected throughout the maintenance period. Events will keep flowing, and BCDs will continue to be created. No data is lost, but there might be small delay in processing If customers are using the Elements APIs directly they can retry after the maintenance break is over. All data that was created during maintenance will be there Note: WithSecure Countercept is not affected by this Maintenance break
We apologize for any disruption this maintenance period may cause.
Posted Nov 17, 2025 - 08:17 UTC
This scheduled maintenance affected: WithSecure Elements managed services (Elevate, Co-Monitoring, Managed Detection and Response, Infinite) and WithSecure Elements (Endpoint Detection and Response, API).