Systems Status

Devices may not be visible in the WithSecure Elements Security Center despite devices being protected and licenses are taken into use

Incident Report for WithSecure services

Update

We have limited the impact to a small set of customers.
Affected customers may experience also an TX-ID error when elevating a BCD from an affected device.
In this case, please reach out to Technical Support with the BCD ID.

https://www.withsecure.com/en/support/contact-support/call-support

We continue working on this issue.
Posted Feb 20, 2025 - 14:27 UTC

Investigating

We are investigating an issue where some installed WithSecure Elements devices may not be visible in the Elements Security Center despite devices being protected and licenses are taken into use.
Posted Feb 19, 2025 - 14:04 UTC
This incident affects: WithSecure Elements Endpoint Protection (Portal) and WithSecure Elements Endpoint Detection and Response (Portal).