Systems Status
Software Updater detects cumulative update (KB5029263) for Windows 11 repeatedly even after update and restart.
Incident Report for WithSecure services
Resolved
WithSecure Elements Endpoint Protection 23.7 was released and is installed automatically by hosts.
This release resolves the issue.
Posted Sep 29, 2023 - 07:00 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 22, 2023 - 07:09 UTC
Identified
We have released a fix for the issue for our customers using Business Suite.
The update is automatically installed. The update is listed as released F-Secure Software Updater Engine 2023-09-21_01.

For customers using WithSecure Elements, the fix is included in the next version 23.7 which we aim to release late next week.
The new version is already available to customers in Early Access.
You can join the Early Access program through the WithSecure Elements Portal. Navigate to profile settings, general settings, early access.
Posted Sep 21, 2023 - 08:06 UTC
Investigating
Currently Software Updater detects cumulative update (KB5029263) for Windows 11 repeatedly even after update and restart.
This issue only affects Windows 11.

We apologize for the inconvenience and are working on fixing the issue.
Posted Sep 07, 2023 - 08:32 UTC
This incident affected: WithSecure Business Suite (Endpoints (Clients & Servers)) and WithSecure Elements Endpoint Protection (Endpoints (Clients & Servers)).