Systems Status

WithSecure Elements portal inaccessible

Incident Report for WithSecure services

Resolved

The incident has been resolved, all services have recovered.
Posted Oct 20, 2025 - 10:38 UTC

Identified

WithSecure services and portals are recovering.

We continue to work on fully restoring all services.
Posted Oct 20, 2025 - 09:34 UTC

Update

WithSecure Cloud Protection for Salesforce is impacted by the current outage as well.
Advanced Scanning & Large File Scanning as well as File Reputation lookups and backups are not working.
Small file & Url Scanning is working.

We continue working on the issue with the highest priority.
Posted Oct 20, 2025 - 08:47 UTC

Update

Currently login to WithSecure Elements Security Center is not possible. We are investigating whether this is related to wider issues with Amazon Web Services.
Posted Oct 20, 2025 - 08:16 UTC

Investigating

We are investigating an issue where WithSecure Elements portal is inaccessible.

Please follow this incident for updates.
Posted Oct 20, 2025 - 07:35 UTC
This incident affected: WithSecure Elements Endpoint Protection (Portal), WithSecure Elements Exposure Management (Portal), WithSecure Cloud Protection for Salesforce (Backend), WithSecure Elements Collaboration Protection (Portal), and WithSecure Elements Endpoint Detection and Response (Portal).