Systems Status

Microsoft Sentinel connector is not receiving security event data from WithSecure Elements

Incident Report for WithSecure services

Identified

We are in the process of releasing a new version that resolves this issue. This version is currently pending Microsoft approval.

In the meantime, you can manually upgrade the WithSecure Elements API connector for Microsoft Sentinel (deployed from Azure Marketplace) by following these steps:

Login to Azure CLI
az login
Download the Fixed Version of the Connector App from:
https://github.com/WithSecureOpenSource/elements-api/releases/download/1.0.1/connector.zip
Run the Function App Deployment (Modify the MyResourceGroupName and MyFunctionAppName as needed):
az functionapp deployment source config-zip --resource-group MyResourceGroupName --name MyFunctionAppName --src ./connector.zip
Posted May 12, 2025 - 12:24 UTC

Investigating

We are currently investigating an issue where the Microsoft Sentinel connector is not receiving security event data from WithSecure Elements.
Affected are all customers using the Sentinel connector.
Posted May 08, 2025 - 11:27 UTC
This incident affects: WithSecure Elements Endpoint Protection (Portal).