Systems Status
Elements Endpoint Protection Portal is not accessible (US region)
Incident Report for WithSecure services
Resolved
This is incident is now resolved. Portal logins tested and it works fine for US region. All works normally now.
Posted Jun 13, 2023 - 22:52 UTC
Monitoring
The service has been recovered and Elements Endpoint Protection Portal should be accessible as per usual now. The related team is still working on a full recovery and we will continue to monitor the issue.
Posted Jun 13, 2023 - 20:54 UTC
Identified
We have identified that our Elements Endpoint Protection Portal is not accessible(US region).

Currently, the issue has been identified and the related team is working on the fix. Some might be able to login, but it will not show any subscription.

We sincerely apologize for the inconvenience caused and are working on fixing the issue as soon as possible.
Posted Jun 13, 2023 - 20:33 UTC
This incident affected: WithSecure Elements Endpoint Protection (Portal).