Systems Status

WithSecure Elements Collaboration Protection outage

Incident Report for WithSecure services

Resolved

We have restored the service.
The downtime lasted from 09:30 UTC to 13:15 UTC in which significant portion of content was not scanned.
Posted Feb 28, 2025 - 13:43 UTC

Investigating

We are investigating a major outage of WithSecure Elements Collaboration Protection.
We estimate that a significant portion of mailboxes are not protected.
Also Sharepoint, OneDrive and Teams protection are partially affected.

We work with the highest priority on this issue.
Posted Feb 28, 2025 - 12:51 UTC
This incident affected: WithSecure Elements Collaboration Protection (Portal, Scan Nodes).