Systems Status

Support page is not accessible from withsecure.com corporate page

Incident Report for WithSecure services

Identified

A temporary fix has been deployed. On some localized pages, the English support page may still be displayed. In the meantime, partners and users can refer to the available content and switch the language manually in certain sections, such as the User Guide. We will continue working on a full resolution as a high priority.
Posted Jun 05, 2026 - 00:36 UTC

Investigating

We have identified an issue where support page is not accessible from withsecure.com corporate page.
We are working on a solution with the highest priority.

Direct access to English support page https://support.withsecure.com/ is working.
Posted Jun 04, 2026 - 10:34 UTC
This incident affects: WithSecure Support (Email Support Form).