Systems Status
HTTP 504 error when trying to download Elements Endpoint Protection installer..
Incident Report for WithSecure services
Resolved
Our download servers are restored and you can download WithSecure Elements and WithSecure Business Suite products again.

We apologize for the outage.
Posted Jun 22, 2023 - 12:51 UTC
Update
We continue working on resolving this incident with the highest priority.

Symptoms are
- unable to download WithSecure Elements Endpoint Protection installation files
- WithSecure Elements Endpoint Protection installation may fail
- WithSecure Business Suite download page shows no files to download

There is no impact on already installed hosts.
Posted Jun 22, 2023 - 12:03 UTC
Identified
We have identified the cause and working on a solution.

This is only affecting new downloads and installations. Rest assured that all other services such as installed host, database updates, security cloud functionality is not affected with this issue.

We are still working diligently on fixing the issue.
Posted Jun 22, 2023 - 06:55 UTC
Investigating
We have identified WithSecure download server, https://download.sp.withsecure.com is down.
Any attempt to download installer during this period of time will fail as you'll be getting gateway timeout error.

We are currently investigating and working on fixing the issue.
Posted Jun 22, 2023 - 03:43 UTC
This incident affected: WithSecure Elements Endpoint Protection (Portal).