Systems Status
WithSecure Elements Collaboration Protection may scan old emails and send alerts for detections in old emails
Incident Report for WithSecure services
Resolved
This incident has been resolved.
Posted Aug 22, 2023 - 14:16 UTC
Monitoring
Issue has been identified and a fix for Collaboration Protection has been deployed.

We sincerely apologize for the inconvenience.
Posted Aug 17, 2023 - 00:56 UTC
Investigating
A subset of WithSecure Elements Collaboration Protection customers are receiving alerts for detections in old emails.
We found that changes on Microsoft side caused the scanning of these older items.

We continue investigating the issue.

We apologize for the inconvenience caused.
Posted Aug 15, 2023 - 12:35 UTC
This incident affected: WithSecure Elements Collaboration Protection (Portal).