Systems Status

WithSecure Elements: Creation of Broad Context Detections delayed

Incident Report for WithSecure services

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 13:59 UTC

Investigating

We are investigating a delay in the creation of Broad Context Detections (BCD) in WithSecure Elements Endpoint Detection and Response.
BCDs appear with a delay of up to 40 Minutes in the WithSecure Elements portal.

We are working to reduce the delay with the highest priority.
Posted Jun 12, 2025 - 12:13 UTC
This incident affected: WithSecure Elements Endpoint Detection and Response (Detection Processing).