Systems Status

The change subscription operation resulted in devices going missing in the Elements Security Center

Incident Report for WithSecure services

Resolved

This incident has been resolved.
Posted Jan 05, 2025 - 22:57 UTC

Monitoring

We have received reports that devices go missing in the Elements Security Center after performing the subscription change operation.

We have released a fix and currently monitoring the issue.
Posted Jan 03, 2025 - 16:13 UTC

Investigating

We have received reports that devices go missing in the Elements Security Center after performing the subscription change operation.

We are currently investigating the issue and working diligently to resolve it.

Thank you for your patience as we work towards a solution.
Posted Jan 03, 2025 - 08:21 UTC
This incident affected: WithSecure Elements Endpoint Protection (Portal) and WithSecure Elements Endpoint Detection and Response (Portal).