Systems Status
WithSecure Elements Endpoint Detection and Response: Delays in processing
Incident Report for WithSecure services
Resolved
This incident is resolved.
Posted Apr 21, 2023 - 06:24 UTC
Monitoring
We can confirm that all new incidents are processed in real time. A small number of incidents that were generated before 19th of April 14:00 UTC, may still appear with a delay for a small subset of our customers.
Posted Apr 20, 2023 - 07:00 UTC
Identified
The fix applied yesterday has resolved the delays in most cases, however we are still seeing delays for a small subset of customers. We continue working on the issue.
Posted Apr 19, 2023 - 07:01 UTC
Monitoring
We have deployed a fix and are expecting processing times to normalize in the next hours, but no later than by the end of the day.

We will continue to monitor the situation.
Posted Apr 18, 2023 - 14:20 UTC
Investigating
We are currently investigating delays in processing of incidents in WithSecure Elements Endpoint Detection and Response.
Incidents may register in the portal only after several hours.

We apologize for the inconvenience and are working on eliminating the delay.
Posted Apr 18, 2023 - 07:40 UTC
This incident affected: WithSecure Elements Endpoint Detection and Response (Detection Processing).