Systems Status

MS domain(aka.ms) is blocked as harmful in ECP

Incident Report for WithSecure services

Resolved

This issue has been resolved.
Posted Dec 03, 2025 - 04:11 UTC

Investigating

MS domain(aka.ms related domain) is blocked as harmful in Elements Collaboration Protection(ECP). Visible effects of this is that mail sending/receiving are blocked in ECP
Posted Dec 03, 2025 - 02:50 UTC
This incident affected: WithSecure Elements (Collaboration Protection).