Systems Status
Performance degradation after UlCore update 2023-08-22_01
Incident Report for WithSecure services
Resolved
This incident has been resolved.
Posted Oct 05, 2023 - 08:25 UTC
Investigating
We have taken the decision to revert the latest release and have just published the Ultralight Core 2023-08-31_01 update.
The update will be taken automatically in use. No reboot is required.

This update resolves the issue for all affected customers.

We continue to investigate the root cause of the issue with high priority.
Posted Aug 31, 2023 - 16:20 UTC
Monitoring
We have received reports that some Windows servers running WithSecure Elements Endpoint Protection or WithSecure Business Suite Server Security are suffering from generally slow performance.

This may manifest as users not being able to logon to terminal servers or some applications responding unusually slow.

Currently we have released the fix and we are monitoring the issue.

Please subscribe to this incident for status updates.

We apologize for the inconvenience.
Posted Aug 30, 2023 - 23:22 UTC
Investigating
We have received reports that some Windows servers running WithSecure Elements Endpoint Protection or WithSecure Business Suite Server Security are suffering from generally slow performance.

This may manifest as users not being able to logon to terminal servers or some applications responding unusually slow.

We are working to isolate the issue and resolve it.

Please subscribe to this incident for status updates.

We apologize for the inconvenience.
Posted Aug 30, 2023 - 13:13 UTC
This incident affected: WithSecure Business Suite (Endpoints (Clients & Servers)) and WithSecure Elements Endpoint Protection (Endpoints (Clients & Servers)).