Systems Status

Cannot log in to the Elements Security Center

Incident Report for WithSecure services

Resolved

This incident has been resolved.
Posted Mar 06, 2025 - 13:46 UTC

Monitoring

The service has now been restored, logging in to Elements Security Center working correctly.
Posted Mar 06, 2025 - 13:14 UTC

Investigating

We are currently investigating an issue where logging in to WithSecure Elements security Center fails.
Posted Mar 06, 2025 - 13:02 UTC
This incident affected: WithSecure Elements Endpoint Protection (Portal), WithSecure Elements Exposure Management (Portal), WithSecure Elements Collaboration Protection (Portal), and WithSecure Elements Endpoint Detection and Response (Portal).