Systems Status
Error message when trying to remove a device from WithSecure Elements portal devices page
Incident Report for WithSecure services
Resolved
The issue has been resolved.
We apologize for the inconvenience caused.
Posted Nov 14, 2024 - 14:15 UTC
Investigating
We are currently investigating reports of an error message when attempting to remove a device from the WithSecure Elements portal’s Environment > Devices page.
Posted Nov 14, 2024 - 14:03 UTC
This incident affected: WithSecure Elements Endpoint Protection (Portal).