Systems Status
WithSecure support webpage is down "404: The page could not be found".
Incident Report for WithSecure services
Resolved
This incident has been resolved.
Posted Feb 13, 2024 - 14:22 UTC
Monitoring
The issue has been resolved.

We apologize for the inconvenience caused.
Posted Feb 13, 2024 - 09:55 UTC
Investigating
Currently you'll not be able to raise a support ticket via support page, submission page showing the error "404: The page could not be found".

We're in the midst of investigating the root cause and to fix the issue.

Meanwhile, please find our support contact number here to file a ticket to us, https://www.withsecure.com/en/support/contact-support/call-support.

We sincerely appreciate your patience on this matter and apologize for the inconvenience caused.
Posted Feb 13, 2024 - 02:05 UTC
This incident affected: WithSecure Support (Email Support Form).