Systems Status

Cosmos in degraded state due to heavy queries

Incident Report for WithSecure services

Resolved

This incident is now resolved.
Posted Jul 11, 2025 - 11:59 UTC

Monitoring

The root cause has been identified and a fix has been applied. The situation is now back to normal.

As of 12:00 UTC, Cosmos is still processing the backlog of PUSH notifications.
Posted Jul 04, 2025 - 00:43 UTC

Investigating

Cosmos is currently experiencing a degraded state due to high query volume, which may be causing delays in remote operations via PUSH.

We are actively investigating the cause of the issue and will provide updates as soon as it's identified.
Posted Jul 03, 2025 - 10:01 UTC
This incident affected: WithSecure Elements Endpoint Protection (Portal, Endpoints (Clients & Servers)), WithSecure Business Suite (Endpoints (Clients & Servers)), and WithSecure Elements Endpoint Detection and Response (Portal).