Systems Status

Contact Support form not working

Incident Report for WithSecure services

Resolved

The issue has been resolved.
If you have submitted a support request and have not received a reply from our system with a case number, your request has not reached us.
We kindly ask you to submit your request again.

We apologize for the inconvenience caused.
Posted Jan 21, 2026 - 15:31 UTC

Investigating

We are investigating an issue with our "contact support" webform.
Submissions do not reach our ticketing system and no error message is displayed.
While we investigate the issue, we ask Partners to submit support requests through Partner Portal.
Eligible customers can submit support requests through eService portal.
In urgent matters, please give us a call.
Our contact numbers and opening hours are listed here: https://support.withsecure.com/en/support/contact-support/call-support
Posted Jan 21, 2026 - 13:59 UTC
This incident affected: WithSecure Support (Email Support Form).