Systems Status
Webform submission showing error "Please check the data you sent" when trying to file a support ticket.
Incident Report for WithSecure services
Resolved
This incident has been resolved.
Posted Dec 21, 2023 - 09:04 UTC
Monitoring
Fix has been identified and deployed.

Meanwhile if you still have issue to submit a support ticket via https://www.withsecure.com/en/support/contact-support/email-support, please clear the browser's cache.
Posted Dec 21, 2023 - 05:35 UTC
Investigating
You'll encounter error "Please check the data you sent" while trying to file a support ticket with us.
We're in the midst of investigating the root cause and to fix the issue.

Meanwhile, please find our support contact number here to file a ticket to us, https://www.withsecure.com/en/support/contact-support/call-support.

We sincerely appreciate your patience on this matter and apologize for the inconvenience caused.
Posted Dec 21, 2023 - 02:06 UTC
This incident affected: WithSecure Support (Email Support Form).