Systems Status

WithSecure Elements URL sample submission outage

Incident Report for WithSecure services

Resolved

The issue has been resolved.
You can submit URL samples again.
Thank you for your patience!
Posted Apr 23, 2026 - 12:25 UTC

Investigating

We are currently experiencing an issue were submitting URL samples in WithSecure Elements fails with an error "cannot create collaboration request".
We are working on a solution with the highest priority.
Posted Apr 23, 2026 - 11:08 UTC
This incident affected: WithSecure Elements (Portal).