Systems Status

WithSecure Business Suite: Policy Manager not able to register to WithSecure

Incident Report for WithSecure services

Resolved

This incident has been resolved.
Posted Oct 13, 2025 - 05:16 UTC

Update

We are continuing to investigate this issue.
Posted Oct 08, 2025 - 11:53 UTC

Investigating

We are investigating an issue where WithSecure Policy Manager Server is unable to register to our backend.
Existing Policy Manager installations will continue to function. New installations will fail to register, you can use Policy Manager in Trial mode.

Security functionality and updates are not affected.
Posted Oct 07, 2025 - 10:06 UTC
This incident affected: On-Premise solutions (Business Suite).