Systems Status

Submit Support Request from support pages not working

Incident Report for WithSecure services

Resolved

If you have submitted a support request between Monday, 11th of August and Wednesday, 13th of August and have not received an automatic response with a support case ID, please contact us again. In urgent cases, please give us a call.

We apologize for the inconvenience caused.
Posted Aug 15, 2025 - 07:28 UTC

Identified

We are currently investigating recovery options for submitted Support Requests that did not reach us and will update this incident with more information, as it becomes available.
Posted Aug 14, 2025 - 06:33 UTC

Monitoring

The main issue has been solved. WithSecure support page can accept new support requests.
Next Steps are to recover the dropped cases.
Posted Aug 14, 2025 - 00:44 UTC

Identified

We have identified and resolved the issue, new Support Requests created from our webform are again reaching us.
When submitting a case, you will get an automatic response with a case number.
https://www.withsecure.com/en/support/contact-support/email-support

We are currently investigating recovery options for submitted Support Requests that did not reach us and will update this incident with more information, as it becomes available.
Posted Aug 13, 2025 - 09:53 UTC

Investigating

We are currently investigating an issue where submitting a support request from our support pages does not work.
There is no error message on the webform.

If you have submitted a support request and have not received an automated response with a case number, you are affected.

Partners: Please submit your support request from the Partner Portal
Customers with advanced or premium support: Please submit your support request from the eService portal
Other customers: Please submit your support request again, once the issue is resolved.

In urgent cases, please give us a call.
Our phone numbers and opening hours: https://www.withsecure.com/en/support/contact-support/call-support

Login to Partner Portal and eService:
https://www.withsecure.com/en/login
Posted Aug 13, 2025 - 08:01 UTC
This incident affected: WithSecure Support (Email Support Form).