Systems Status
Countercept Agent for Linux consuming high CPU after new release.
Incident Report for WithSecure services
Resolved
This incident has been resolved.
Posted Jun 12, 2023 - 07:04 UTC
Update
We continue monitoring the situation closely.
Posted Jun 07, 2023 - 11:17 UTC
Monitoring
We have released a new sensor database update that improves performance. The update will be taken into use automatically within one hour and no administrator action is required.

You can verify the update installed from /opt/f-secure/mdr/baseguard/var/updated/log/update.log.

The log will show

Update /sensor-db/1685709415 installed successfully.
Posted Jun 02, 2023 - 12:48 UTC
Update
We're still in the midst of working on permanent fix.

Meanwhile, there's additional workaround we can suggest for the issue:
1. Disable the memory scanner that may have caused increased in CPU usage
sudo /opt/f-secure/mdr/baseguard/var/sensor/libexec/sensor_config --set scanners.linux_memory.enabled false
sudo systemctl restart f-secure-mdr-baseguard-sensor
2. Increase environment resources
3. Set limits for the sensor CPU utilization

We apologize for the inconvenience and are still working on fixing the issue.
Posted Jun 02, 2023 - 06:20 UTC
Identified
We have identified that Countercept Agent is consuming high CPU utilization after new release for Linux.

Current workaround:
Disable the new memory scanner which is the most likely cause for the problem.
sudo /opt/f-secure/mdr/baseguard/var/sensor/libexec/sensor_config --set scanners.linux_memory.enabled false
sudo systemctl restart f-secure-mdr-baseguard-sensor

We apologize for the inconvenience and are working on fixing the issue.
Posted Jun 01, 2023 - 08:31 UTC
This incident affected: WithSecure Countercept (Sensor).